Ms Visual Studio and OpenCV

Step 1: Installing the software

Install Ms Visual Studio 2008 See the Microsoft website for instructions on how to obtain MSVS (Microsoft Visual Studio).

Install OpenCV See this website for instructions.

Install the Ms SDK See __this website_ for instructions._

Step 2: Setting up MSVS

Include opencv in the project settings from MSVS. See this webpage for instructions. I will not copy them as that can only introduce errors.

Step 3: Setting up Ms Windows

All that is left now is the PATH settings from Windows. First right click on “My Computer”, click on “Properties” then “Advanced System Settings” and finally “Environment Variables”. Now we have to add the path of the OpenCV /lib directory to the “PATH” in the System “Variables window”

Finally

… this is all to get running. Now you can start to get moving with the powerfull OpenCV framework.

Comments

Anonymous (not verified)

. July 1st, 2008

I failed earlier to run an OpenCV program successfully. After going through the links provided I succeeded in running the program. Thanks for posting them.

Anonymous (not verified)

. January 14th, 2009

I have the same problem. Would you please tell me what links helped you solve the problem? Thanks.

patrick

. January 17th, 2009

 I think/hope that he means the links provided in the article above.

gr. P

Anonymous (not verified)

. July 9th, 2009

 I have had same problem.To solve this  File->Open>Project then navigate to OpenCV\cxcore folder in src file you will see cxcore solution then click on it.Visual studio will ask you something then click ok or whatever.Done.

Anonymous (not verified)

. September 12th, 2009

  I did not find a cxcore solution file in the cxcore source folder Please helpme

Anonymous (not verified)

. September 12th, 2009

I chose the cxcore vc++ proj file in cxcore\src folder in microsoft vs 2008 Yet,I could not get rid of the cxcore100.dll not found error

Anonymous (not verified)

. November 12th, 2008

Hi,

I installed OpenCV with Visual Studio 2008 on Windows Vista. I have followed all the steps mentioned. I wrote a simple program for inversion of an image. It is compiling properly but when I try and run it, I get the following error- “LDR: LdrpWalkImportDescriptor() failed to probe C:\Program Files\OpenCV\bin\cxcore110.dll for its manifest, ntstatus 0xc0150002 “

Please tell me what can I do?

Thanks

Anonymous (not verified)

. December 4th, 2008

I had the same problem - a dependency problem in the dll’s. I rolled back to version 1.0 of OpenCV and it was fine. From a few things I read online it looks like it might be depending on a Vista only dll? Not sure.

Anonymous (not verified)

. April 3rd, 2009

I’ve followed the instructions above to the point including building the OpenCV debug and release versions successfully. It still doesn’t work every time I try to use any cx… files i get cxcore110.dll error. The opencv programs not involving those files work fine… I’m getting rather desperate atm… Please advice if there is anything else I can do?

//Martin

Anonymous (not verified)

. April 3rd, 2009

And I have windows xp not vista.

Remaining comments are removed :-)